Other cryptos are partially unavailable
Incident Report for Nanswap
Resolved
This incident has been resolved.
Posted Nov 25, 2022 - 19:50 UTC
Monitoring
0 network fees/Other Cryptocurrencies Pairs of our partner are in maintenance
Posted Nov 23, 2022 - 13:00 UTC
This incident affected: Other Cryptocurrencies (Other Cryptocurrencies).